Cant get new task always error

cant get new task always error

the countdown not start


Same issue from yesterday. Though some of my referrals are still earning, not everyone got this bug.


yes, me too… from yesterday. more than 24 hours

Same for me, I can’t perform tasks. Always saying task request errors.

There’s something wrong with your DNS configuration that prevent the extension to work properly , so you should flush your system DNS cache .

Perhaps you should take a step back and stop telling everyone it is on their end. There is no way everyone with this issue has “misconfigured” their DNS nor their providers. The issue is on Clickspaid’s side. Just because mucking with yours seems to work off and on as stated in other posts that doesn’t mean it is actually accurate. If this was just people on the same ISP, it would make more sense. But you are telling everyone that it is THEIR DNS that is the issue. Try again.


The issue is they are IP banning. I got a new IP from my ISP, and the button worked, got some tasks and after a while stopped working again.
Got new IP worked again but only for a short while.
The site is banning IPs from certain regions.

1 Like

I didn’t change my IP and it worked again but it doesn’t work anymore now

It’s working again, thanks Clickspaid for fixing it

I am glad it works for you. But it sure ain’t working for me. Now sure if the admins are ever aware of this problem and work on fixing it.
I suspect some of the services they use, probably Cloudflare, is blocking our IPs.